»查看更多分类

九五至尊 通达信副图指标 源码 贴图

发布时间:2020-04-22 09:52:00  点击:

九五至尊 通达信副图指标 源码 贴图

九五至尊 通达信副图指标 源码 贴图


{公式名称: 九五至尊

画线方法: 副图}
VAR1:=CONST(CLOSE/FINANCE(33));
VAR2:=CONST(DYNAINFO(7)/FINANCE(34));
VAR3:=FINANCE(33)/FINANCE(34)*100;
VAR4:=CONST((FINANCE(20)-FINANCE(21))/FINANCE(20)*100);
VAR5:=FINANCE(30)/FINANCE(20)*100;
VAR6:=FINANCE(23)/FINANCE(20)*100;
VAR7:=FINVALUE(199);
VAR8:=FINANCE(30)/10000;
VAR9:=FINVALUE(184);
VAR10:=CONST(FINANCE(38));
VAR11:=CONST(FINANCE(18));
VAR12:=CONST(FINANCE(32));
VAR13:=FINANCE(34);
VAR14:=VAR3<=0.27;
VAR15:=VAR6<=(-1.27);
VAR16:=VAR5<=0.34;
VAR17:=VAR10<0.002;
VAR18:=VAR12<=0.26;
VAR19:=VAR11<0;
VAR20:=VAR4<=4.2;
抄底风险等于:VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR19 OR VAR20;
VAR21:=CLOSE/MA(CLOSE,40)*100<78;
VAR22:=CLOSE/MA(CLOSE,60)*100<74;
VAR23:=HIGH>LOW*1.051;
VAR24:=VAR23 AND COUNT(VAR23,5)>1;
VAR25:=IF(VAR24 AND (VAR21 OR VAR22),2,0);
VAR26:=CLOSE/REF(CLOSE,25)<=1.1;
VAR27:=SMA(MAX(CLOSE-REF(CLOSE,2),0),7,1)/SMA(ABS(CLOSE-REF(CLOSE,2)),7,1)*100<15;
VAR28:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
VAR29:=SMA(VAR28,2,1);
VAR30:=SMA(VAR29,2,1);
VAR31:=IF(VAR29>REF(VAR29,1) AND REF(VAR29,1)<REF(VAR29,2) AND VAR29<23,1.5,0);
青龙:VAR26 AND VAR25 AND VAR27 AND VAR31,COLORGREEN;
VAR32:=MA(CLOSE,5);
VAR33:=MA(CLOSE,10);
VAR34:=MA(CLOSE,30);
VAR35:=MA(CLOSE,60);
VAR36:=MA(CLOSE,120);
VAR37:=VAR36>VAR35 AND VAR35>VAR34;
VAR38:=VAR34>VAR35 AND VAR35>VAR36;
VAR39:=MAX(VAR34,MAX(VAR35,VAR36));
VAR40:=MIN(VAR34,MIN(VAR35,VAR36));
VAR41:=IF(VAR34!=VAR39 AND VAR34!=VAR40,VAR34,IF(VAR35!=VAR39 AND VAR35!=VAR40,VAR35,VAR36));
VAR42:=(VAR39-VAR40)/VAR40*100;
VAR43:=(VAR41-VAR40)/VAR40*100;
VAR44:=MA(REF(HHV(CLOSE,30),1),2);
VAR45:=MA(REF(LLV(CLOSE,30),1),2);
VAR46:=(VAR44-MAX(CLOSE,OPEN))/MAX(CLOSE,OPEN)*100;
VAR47:=(MIN(CLOSE,OPEN)-VAR45)/VAR45*100;
VAR48:=BARSLASTCOUNT(VAR45<REF(VAR45,1) AND VAR45*1.007>=REF(VAR45,1));
VAR49:=(MAX(CLOSE,OPEN)-MIN(CLOSE,OPEN))/MIN(CLOSE,OPEN)*100;
VAR50:=(HIGH-MAX(CLOSE,OPEN))/MAX(CLOSE,OPEN)*100;
VAR51:=(MIN(CLOSE,OPEN)-LOW)/LOW*100;
VAR52:=BARSLASTCOUNT(MAX(OPEN,CLOSE)<=REF(MAX(OPEN,CLOSE),1) AND MIN(OPEN,CLOSE)<=REF(MIN(OPEN,CLOSE),1))>=2;
VAR53:=(REF(MIN(CLOSE,OPEN),1)-MAX(CLOSE,OPEN))/MAX(CLOSE,OPEN)*100;
VAR54:=BARSLASTCOUNT(VAR49>2.1)>=3 AND BARSLASTCOUNT(VAR53>2.1)>=2 AND COUNT(VAR53>5.5,2) OR (BARSLASTCOUNT(OPEN<REF(OPEN,1) AND CLOSE<REF(CLOSE,1))=2 AND BARSLASTCOUNT(OPEN>CLOSE AND VAR49>4)=3);
VAR55:=RANGE(MIN(CLOSE,OPEN),MA(CLOSE,5)*0.98,MA(CLOSE,5)*1.02);
VAR56:=(MAX(HHV(CLOSE,10),HHV(OPEN,10))-MIN(LLV(CLOSE,10),LLV(OPEN,10)))/MIN(LLV(CLOSE,10),LLV(OPEN,10))*100;
VAR57:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR58:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VAR59:=REF(VAR58,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR60:=REF(VAR58 OR VAR59,1) AND VAR57;
VAR61:=VAR60 AND CLOSE>OPEN;
VAR62:=REF(VAR57,1) AND VAR58 AND NOT(REF(CLOSE,3)=LLV(CLOSE,4));
VAR63:=CLOSE/OPEN>1.04 AND CLOSE<SMA(HIGH,19,3) AND CLOSE>REF(CLOSE,1);
VAR64:=IF(CLOSE>MA(CLOSE,4),1,0)+IF(CLOSE<MA(CLOSE,4),(-1),0)+IF(MA(CLOSE,5)>REF(MA(CLOSE,5),1),1,0)+IF(MA(CLOSE,5)<REF(MA(CLOSE,5),1),(-1),0);
VAR65:=VAR64=(-2) AND CLOSE>OPEN;
VAR66:=IF(CLOSE>MA(CLOSE,4),1,0);
VAR67:=IF(CLOSE<MA(CLOSE,4),(-1),0);
VAR68:=IF(MA(CLOSE,5)>REF(MA(CLOSE,5),1),1,0);
VAR69:=IF(MA(CLOSE,5)<REF(MA(CLOSE,5),1),(-1),0);
VAR70:=VAR66+VAR67+VAR68+VAR69;
VAR71:=VAR70=2 AND CLOSE<OPEN;
VAR72:=EMA((CLOSE*2+HIGH+LOW)/4,13)-EMA((CLOSE*2+HIGH+LOW)/4,73);
VAR73:=CROSS(VAR72,EMA(VAR72,2)) AND VAR72<=0.05 AND CLOSE/REF(CLOSE,1)>0.035;
VAR74:=VAR73 AND NOT(VAR71);
VAR75:=VAR63 AND VAR49>3.9 AND VAR47<0.2 AND CLOSE>VAR45 AND VAR51<1.5 AND REF(VAR50<3,1) AND (REF(VAR49>5.5 AND CLOSE<OPEN,1) AND REF(VAR49,1)>VAR49)=0 AND VAR74=0 AND VAR65=0 AND REF(VAR62 AND VAR74 AND VAR61=0,1)=0 AND REF(VAR61=0,2);
VAR76:=VAR45=REF(VAR45,1) OR VAR48 AND CLOSE<VAR40*1.01 AND BARSLASTCOUNT(VAR40<=REF(VAR40,1))>=7 AND VAR43<11.54 AND (BARSLASTCOUNT(VAR39>VAR44)>=4 AND OPEN<VAR45 OR (BARSLASTCOUNT(VAR39<VAR44)>10 AND OPEN>VAR45 AND VAR42<10)) AND (VAR37 OR CLOSE*1.2<VAR40 OR COUNT(CROSS(VAR34,VAR35),4)) AND BARSLASTCOUNT(VAR41<VAR44)>=7;
VAR77:=VAR75 AND VAR76;
VAR78:=VAR63 AND VAR49>5.4 AND CLOSE=HHV(CLOSE,4) AND OPEN<=REF(MAX(CLOSE,OPEN),1) AND VAR50<1.7 AND VAR74=0 AND VAR65=0 AND (REF(BARSLASTCOUNT(VAR49<1.5 AND VAR55)>=3,1) OR REF(COUNT(VAR52,2)>=1 AND BARSLASTCOUNT(VAR49>1.5)>=3,1)) AND (REF(VAR49>4.5 AND CLOSE<OPEN,1)=0 OR REF(VAR54,1));
VAR79:=VAR47<5.4 AND VAR46<14 AND CLOSE>VAR45 AND CLOSE<VAR39*1.01 AND CLOSE>VAR40 AND BARSLASTCOUNT(VAR39<VAR44)>10 AND (COUNT(VAR54,7) OR REF(VAR56<10,1)) AND (VAR38 OR BARSLASTCOUNT(VAR39>=REF(VAR39,1))>=10);
VAR80:=VAR78 AND VAR79;
VAR81:=VAR52 AND BARSLASTCOUNT(VAR49<2.5)>=3 AND VAR65 AND CLOSE<VAR45 OR VAR54;
VAR82:=BARSLASTCOUNT(CLOSE>0)<60 AND CLOSE<VAR34*1.01 AND CROSS(CLOSE,VAR32) AND CROSS(CLOSE,VAR33) OR (VAR49>5 AND VAR46<14);
VAR83:=VAR63 AND VAR49>3.9 AND VAR47<1.05 AND CLOSE>VAR45 AND CLOSE<VAR34 AND REF(VAR45,1)>REF(VAR45,2) AND VAR45<REF(VAR45,1) AND REF(VAR81,1) AND VAR82;
金龙:VAR77 OR VAR80 OR VAR83,COLORYELLOW;
赤龙:CROSS(RSI.RSI1,11),COLORRED;
白龙:IF(MA(CLOSE,1)<MA(CLOSE,144)*0.45,100,0) OR IF(MA(CLOSE,1)<MA(CLOSE,60)*0.55,100,0),COLORWHITE;
VAR84:=REF(CLOSE,1);{WWW.GPXIAZAI.COM}
VAR85:=SMA(MAX(CLOSE-VAR84,0),7,1)/SMA(ABS(CLOSE-VAR84),7,1)*100;
VAR86:=SMA(MAX(CLOSE-VAR84,0),13,1)/SMA(ABS(CLOSE-VAR84),13,1)*100;
VAR87:=BARSLAST(VAR86<23)<=3 AND CROSS(VAR85,VAR86);
VAR88:=(CLOSE-MA(CLOSE,23))/MA(CLOSE,20)*100<(-12.5);
VAR89:=LLV(LOW,5);
VAR90:=HHV(HIGH,10);
VAR91:=EMA((CLOSE-VAR89)/(VAR90-VAR89)*100,4);
VAR92:=EMA(0.667*REF(VAR91,1)+0.333*VAR91,2);
紫龙:0-(-1)*VAR87 AND VAR88 AND CROSS(VAR91,VAR92) AND VAR91<=25,COLORMAGENTA,LINETHICK2;
VAR93:=1501230;
VAR94:=MA((-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19);
VAR95:=(-100)*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
VAR96:=EMA((-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4);
VAR97:=VAR94+100;
VAR98:=VAR95+100;
VAR99:=VAR96+100;
VAR100:=REF(VAR99,1)>85 AND REF(VAR98,1)>85 AND REF(VAR97,1)>65 AND CROSS(VAR97,VAR98);
VAR101:=VAR99<REF(VAR99,1) AND REF(VAR99,1)>80 AND (REF(VAR98,1)>95 OR REF(VAR98,2)>95) AND VAR97>60 AND VAR98<83.5 AND VAR98<VAR99 AND VAR98<VAR97+4;
VAR102:=FILTER(VAR101,4);
VAR103:=VAR97<12 AND VAR99<8 AND (VAR98<7.2 OR REF(VAR98,1)<5) AND (VAR99>REF(VAR99,1) OR VAR98>REF(VAR98,1)) OR (VAR97<8 AND VAR99<7 AND VAR98<15 AND VAR98>REF(VAR98,1)) OR (VAR97<10 AND VAR99<7 AND VAR98<1);
VAR104:=VAR97<15 AND REF(VAR97,1)<15 AND VAR99<18 AND VAR98>REF(VAR98,1) AND CROSS(VAR98,VAR97) AND VAR98>VAR99 AND (REF(VAR98,1)<5 OR REF(VAR98,2)<5) AND (VAR99>=VAR97 OR REF(VAR98,1)<1);
苍龙:IF(DATE<=VAR93,VAR104,0),COLORCYAN;
VAR105:=MA(HHV(HIGH,485),17);
VAR106:=MA(HHV(HIGH,222),17);
VAR107:=MA(HHV(HIGH,96),17);
VAR108:=MA(LLV(LOW,485),17);
VAR109:=MA(LLV(LOW,222),17);
VAR110:=MA(LLV(LOW,96),17);
VAR111:=MA((VAR108*0.96+VAR109*0.96+VAR110*0.96+VAR105*0.558+VAR106*0.558+VAR107*0.558)/6,17);
VAR112:=MA((VAR108*1.25+VAR109*1.23+VAR110*1.2+VAR105*0.55+VAR106*0.55+VAR107*0.65)/6,17);
VAR113:=MA((VAR108*1.3+VAR109*1.3+VAR110*1.3+VAR105*0.68+VAR106*0.68+VAR107*0.68)/6,17);
VAR114:=MA((VAR111*3+VAR112*2+VAR113)/6*1.738,17);
VAR115:=IF(DATE<=1341231,VAR114,VAR114*DAY);
VAR116:=LOW;
VAR117:=REF(LOW,1);
VAR118:=SMA(ABS(VAR116-VAR117),3,1)/SMA(MAX(VAR116-VAR117,0),3,1)*100;
VAR119:=MA(IF(CLOSE*1.35<=VAR115,VAR118*10,VAR118/10),3);
VAR120:=LLV(LOW,30);
VAR121:=HHV(VAR119,30);
VAR122:=1341231;
VAR123:=IF(DATE<=VAR122,MA(IF(LOW<=VAR120,(VAR119+VAR121*2)/2,0),3),100000000);
朱雀:IF((REF(VAR123,2)>REF(VAR123,3) AND VAR123<REF(VAR123,1))*80,0.01,(-0.5)),COLOR555555,LINETHICK2;
VAR124:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR125:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR126:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR127:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR128:=(VAR125+2*VAR126+3*VAR127)/6;
VAR129:=MA(VAR128,3);
玄武:IF(VAR129<=(-10),0.01,(-0.5)),COLORBLUE,LINETHICK2;
VAR130:=OPEN/HHV(CLOSE,30)<0.78;
VAR131:=CLOSE/MA(CLOSE,50)<0.78;
VAR132:=COUNT(OPEN!=LLV(OPEN,13),3)>=1;
VAR133:=COUNT(HIGH>LOW*1.05,5)>2;
VAR134:=CLOSE<COST(5) AND VAR130 AND VAR131 AND VAR132 AND VAR133;
VAR135:=VAR134 AND CLOSE>REF(HIGH,1);
VAR136:=10;
VAR137:=12;
VAR138:=(MIN(CLOSE,OPEN)+2*HIGH)/3;
VAR139:=(MAX(CLOSE,OPEN)+2*LOW)/3;
VAR140:=((VAR138+VAR139)/2+AMOUNT/(VOL*100))/2;
VAR141:=VAR140-REF(VAR140,1);
VAR142:=MA(VAR141,5)+EMA(VAR140,5);
VAR143:=MA(VAR141,12)+EMA(VAR140,12);
VAR144:=MA(VAR141,21)+EMA(VAR140,21);
VAR145:=MAX(MAX(VAR142,VAR143),VAR144);
VAR146:=MIN(MIN(VAR142,VAR143),VAR144);
VAR147:=(VAR145/VAR146-1)*100;
VAR148:=ATAN((VAR142/REF(VAR142,1)-1)*100)*180/3.1416;
VAR149:=ATAN((VAR143/REF(VAR143,1)-1)*100)*180/3.1416;
VAR150:=ATAN((VAR144/REF(VAR144,1)-1)*100)*180/3.1416;
VAR151:=(-(3*VAR148+2*VAR149+VAR150))/36;
VAR152:=CLOSE/MA(CLOSE,30)<0.75;
VAR153:=CLOSE/MA(CLOSE,50)<0.78;
VAR154:=HIGH/LOW>1.053 AND COUNT(HIGH/LOW>1.053,5)>2;
VAR155:=VAR154 AND (VAR152 OR VAR153);
VAR156:=DMA(EMA(CLOSE,5),SUM(VOL,8)/2.8/CAPITAL);
VAR157:=(CLOSE-VAR156)/VAR156*100;
VAR158:=REF(VAR157,1)<(-34) AND VAR157>REF(VAR157,1) AND REF(VAR157,1)<REF(VAR157,2) AND VAR157-REF(VAR157,1)>1.76 OR VAR155;
VAR159:=MA(INDEXC,13)>1.05*INDEXC;
VAR160:=(CLOSE-REF(CLOSE,21))/REF(CLOSE,21)*10<(-3.3);
VAR161:=(CLOSE-MA(CLOSE,2))/MA(CLOSE,2)*100<(-3.7);
VAR162:=VAR159 AND VAR160 AND VAR161;
VAR163:=CROSS(0.5,VAR162);
VAR164:=CLOSE/MA(CLOSE,30)*100<80;
VAR165:=CLOSE/MA(CLOSE,50)*100<78;
VAR166:=CLOSE/MA(CLOSE,70)*100<72;
VAR167:=VAR164 AND VAR165 AND VAR166;
VAR168:=CROSS(REF(VAR147,1),VAR147) AND EXIST(VAR147>VAR137,3) AND EXIST(VAR151>VAR136,3) AND VAR158 AND VAR163 AND VAR167;
白虎:IF(VAR135 OR VAR168,0.01,(-0.5)),COLORCCDDBB,LINETHICK2;

 
2

友情提示: 股市有风险,投资需谨慎,资料由公式网整理收集

使用必看(为了保障您的权益,请在研究学习资料前了解相关说明)

  • ›› 指标不属于投资资讯产品和推股软件,指标旨在辅助大家提高投资胜率参考而研发,仅供参考学习研究之用,不构成投资建议或未来保证,依此操作买卖,盈亏自负。
  • ›› 该资料仅供学习和研究使用,不得用于商业或者非法用途。本站对于提供的指标公式不拥有任何权利,其版权归该资源的合法拥有者所有,如有侵犯您的版权,请查看《公式网的侵权处理流程》,本站将于五个工作日内移除相关内容。
  • ›› 如果您发现下载链接错误,请点击报告错误谢谢!

找不到你要的公式?给我们建议