»查看更多分类

通达信红飘带副图指标 源码 贴图

发布时间:2023-11-17 10:31:00  点击:

通达信红飘带副图指标 源码 贴图

通达信红飘带副图指标 源码 贴图

通达信红飘带副图指标 源码 贴图

N日:=2;
VAR1:=EMA(EMA(CLOSE,9),9);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
A10:=CROSS(控盘,0);
做多:=IF(A10,5,0);
X_1:=MA(CLOSE,10);
X_2:=MA(CLOSE,20);
X_3:=MA(CLOSE,30);
X_4:=MA(CLOSE,54);
X_5:=MA(CLOSE,60);
X_6:=MA(CLOSE,120);
X_7:=(REF(CLOSE,3)-CLOSE)/REF(CLOSE,3)*100>5;
X_8:=FILTER(X_7,10);
X_9:=BARSLAST(X_8);
X_10:=REF(HIGH,X_9+2);
X_11:=REF(HIGH,X_9+1);
X_12:=REF(HIGH,X_9);
X_13:=MAX(X_10,X_11);
X_14:=MAX(X_13,X_12);
X_15:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>5;
X_16:=X_9<150;
X_17:=(OPEN-X_14)/X_14*100<30;
X_18:=(CLOSE-LLV(LOW,X_9))/LLV(LOW,X_9)*100<50;
X_19:=(CLOSE-REF(OPEN,5))/REF(OPEN,5)*100<30;
X_20:=VOL/MA(VOL,5)<3.5;
X_21:=(CLOSE-REF(CLOSE,89))/REF(CLOSE,89)*100<80;
X_22:=X_15 AND X_16 AND X_17 AND X_18 AND X_19 AND X_20 AND X_21;
X_23:=FILTER(X_22,15);
X_24:=(CLOSE-X_4)/X_4<0.1;
X_25:=(CLOSE-X_1)/X_1<0.3;
X_26:=(X_24=1 AND X_25=1)*0.2;
X_27:=(X_26=0 AND REF(X_26,1)=0.2 AND REF(COUNT(X_26=0.2,10)=10,1)=1)*(-0.1);
X_28:=X_27=(-0.1);
X_29:=X_23 OR X_28;
X_30:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
X_31:=DYNAINFO(7)/REF(CLOSE,1)>1.05{ AND DYNAINFO(7)/OPEN>1.05};
X_32:=VOL/REF(VOL,1)>1.2 AND COUNT(CLOSE>OPEN,1) OR (LOW>REF(HIGH,1) AND COUNT(OPEN>CLOSE,1) AND VOL/REF(VOL,1)>1.2);
妖股:=X_29 AND CLOSE/REF(CLOSE,1)>1.05 AND X_32 AND X_31;
LCZ:=REF(CLOSE,1);
RSIZ:=((SMA(MAX((CLOSE - LCZ),0),3,1) / SMA(ABS((CLOSE - LCZ)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
VAR91:=IF(YEAR>=2038 AND MONTH>=1,0,1);
VAR92:=REF(LOW,1)*VAR91;
VAR93:=SMA(ABS(LOW-VAR92),3,1)/SMA(MAX(LOW-VAR92,0),3,1)*100*VAR91;
VAR94:=EMA(IF(CLOSE*1.3,VAR93*10,VAR93/10),3)*VAR91;
VAR95:=LLV(LOW,30)*VAR91;
VAR96:=HHV(VAR94,30)*VAR91;
VAR97:=IF(MA(CLOSE,58),1,0)*VAR91;
VAR98:=EMA(IF(LOW<=VAR95,(VAR94+VAR96*2)/2,0),3)/618*VAR97*VAR91;
吸筹:=IF(VAR98>100,100,VAR98)*VAR91,COLORFFC0CB;
庄家吸筹:STICKLINE(吸筹>-150,0,吸筹*0.05,5,0),COLORRED;
VARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
VAR10:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR11:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR12:=VAR10<REF(VAR11,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
DRAWTEXT(VAR12 AND COUNT(VAR12,30)=1,0.6,'—大资金!');
资金进场:VAR12 AND COUNT(VAR12,30)=1,NODRAW;
STICKLINE(资金进场,0,2,3,0),COLORBLUE;
MA5:=MA(CLOSE,5);
MA13:=MA(CLOSE,13);
MA21:=MA(CLOSE,21);
MA34:=MA(CLOSE,34);
MA55:=MA(CLOSE,55);
MA144:=MA(CLOSE,144);
MA233:=MA(CLOSE,233);
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
V144:=MA(V,144);
TJ1:=CROSS(V,V144);
TJ2:=C>MA233 AND C/MA233<1.15;
TJ3:=做多=5 AND MA233>REF(MA233,1);
TJ4:=妖股=1;
金山红牛:C<60 AND TJ2 AND TJ3 AND TJ4,NODRAW;
主趋势线:=EMA(EMA(C,10),10);
AAAZ:=(3*C+H+L+O)/6;
VAR101:=(8*AAAZ+7*REF(AAAZ,1)+6*REF(AAAZ,2)+5*REF(AAAZ,3)+4*REF(AAAZ,4)+3*REF(AAAZ,5)+2*REF(AAAZ,6)+REF(AAAZ,8))/36;
VAR201:=(HHV(VAR101,5)+HHV(VAR101,10)+HHV(VAR101,20))/3;
VAR301:=(LLV(VAR101,5)+LLV(VAR101,10)+LLV(VAR101,20))/3;
VAR401:=(HHV(VAR201,5)+HHV(VAR201,10)+HHV(VAR201,20))/3;
VAR501:=(LLV(VAR301,5)+LLV(VAR301,10)+LLV(VAR301,20))/3;
VAR601:=(LLV(VAR101,2)+LLV(VAR101,4)+LLV(VAR101,6))/3;
短线:=VAR101;
NOTEXT1:=IF(C>=短线,短线,DRAWNULL);
NOTEXT2:=IF(C<短线,短线,DRAWNULL);
中线:=VAR601;
M1:=VAR101>VAR601;
M2:=VAR101<=VAR601;
红飘带:M1 AND LAST(M2,N日,1) AND C>中线 AND C>REF(C,1) AND C>MA(CLOSE,144)
AND O<MA(CLOSE,144) AND C>MA233 AND C>MA(CLOSE,60) AND O<MA(CLOSE,60),NODRAW;
S1:=IF(CODELIKE('688'),0,1);
S2:=IF(NAMELIKE('S'),0,1);
S3:=IF(NAMELIKE('*'),0,1);
TJ5:=S1 AND S2 AND S3;
红牛:C<60 AND TJ2 AND TJ4 AND TJ5,NODRAW;
STICKLINE(红牛,0,2.6,3,0),COLORWHITE;
STICKLINE(红牛,0,1.7,1.3,0),COLORRED;
STICKLINE(红牛,1.7,3.4,1.3,0),COLORYELLOW;
DRAWTEXT(红牛,0.8,'—红牛'),COLORWHITE;{红牛初选}
STICKLINE(金山红牛,0,3,2,0),COLORYELLOW;
STICKLINE(金山红牛,0.3,0.5,2,0),COLORRED;
STICKLINE(金山红牛,2.7,2.5,2,0),COLORRED;
DRAWTEXT(金山红牛,1.5,'—金山红牛'),COLORWHITE;
STICKLINE(红飘带,3.2,2.8,1,0),COLORRED;
STICKLINE(红飘带,2.8,2.4,1.5,0),COLORMAGENTA;
STICKLINE(红飘带,2.4,2,2,0),COLORYELLOW;
STICKLINE(红飘带,2,1.6,2.2,0),COLORMAGENTA;
STICKLINE(红飘带,1.6,1.2,2.5,0),COLORRED;
STICKLINE(红飘带,1.2,0.8,3,0),COLORCYAN;
STICKLINE(红飘带,0.8,0.4,4,0),COLORYELLOW;
STICKLINE(红飘带,0.4,0,5,0),COLORWHITE;
DRAWICON(红飘带,3,13);
DRAWTEXT(红飘带,2.2,'—红飘带'),COLORWHITE;
{板块市值业绩}{公式网WWW.GPXIAZAI.COM}
所属板块:=STRCAT('【所属板块】',STRCAT(STRCAT(STRCAT(' [行业]—',HYBLOCK),STRCAT(' [地域]—',DYBLOCK)),STRCAT(' [概念]—',GNBLOCK)));
总股本:=STRCAT(STRCAT(' 总股本:',CON2STR(TOTALCAPITAL/1000000,2)),'亿');
流通盘:=STRCAT(STRCAT(' 流通盘:',CON2STR(CAPITAL/1000000,2)),'亿');
全流通:=STRCAT(STRCAT(' 全流通:',CON2STR(CAPITAL/TOTALCAPITAL*100,2)),'%');
市值:=STRCAT(STRCAT(' 流通市值:',CON2STR((CAPITAL/1000000)*C,2)),'亿');
上市日期:=STRCAT(' 上市日期: ',CON2STR(HHV((BARSCOUNT(C)=0)*(DATE+19000000),0),0));
股本市值:=STRCAT('【股本市值】',STRCAT(STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值),上市日期));
市盈率:=STRCAT(' 市盈率:',CON2STR(C/FINANCE(33),2));
市销率:=STRCAT(' 市销率:',CON2STR(C/(FINANCE(20)/FINANCE(1)),2));
市净率:=STRCAT(' 市净率:',CON2STR(C/FINANCE(34),2));
净资收益率:=STRCAT(' 净资收益率:',CON2STR(FINANCE(33)/FINANCE(34)*100,2));
毛利率:=STRCAT(' 毛利率:',CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));
净利润率:=STRCAT(' 净利率:',CON2STR(FINANCE(30)/FINANCE(20)*100,2));
主营利润率:=STRCAT(' 主营利润率:',CON2STR(FINANCE(23)/FINANCE(20)*100,2));
当前业绩:=STRCAT('【当前业绩】',STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(市盈率,市销率),市净率),净资收益率),毛利率),净利润率),主营利润率));
DRAWTEXT_FIX(ISLASTBAR,0.005,0.2,0,所属板块),COLORMAGENTA;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.4,0,股本市值),COLORMAGENTA;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.6,0,当前业绩),COLORMAGENTA;


 

 
0

友情提示: 股市有风险,投资需谨慎,资料由公式网整理收集

使用必看(为了保障您的权益,请在研究学习资料前了解相关说明)

  • ›› 指标不属于投资资讯产品和推股软件,指标旨在辅助大家提高投资胜率参考而研发,仅供参考学习研究之用,不构成投资建议或未来保证,依此操作买卖,盈亏自负。
  • ›› 该资料仅供学习和研究使用,不得用于商业或者非法用途。本站对于提供的指标公式不拥有任何权利,其版权归该资源的合法拥有者所有,如有侵犯您的版权,请查看《公式网的侵权处理流程》,本站将于五个工作日内移除相关内容。
  • ›› 如果您发现下载链接错误,请点击报告错误谢谢!

找不到你要的公式?给我们建议