»查看更多分类股票软件

自用的综合指标 通达信主图/副图指标 源码 贴图

发布时间:2019-12-10 09:54:00  点击:

自用的综合指标 通达信主图/副图指标 源码 贴图

主图包含基本资料,股东人数,人均持股,自动划分黄金分割线,箱体的顶底,获利筹码。

自用的综合指标 通达信主图/副图指标 源码 贴图


{基本资料}
品种类型:=FINANCE(3);
所属板块:=HYBLOCK;
上市天数:=FINANCE(42);
股总市值:=ROUND(FINANCE(41)/100000000);
流通市值:=ROUND(FINANCE(40)/100000000);
股东人数:=FINANCE(8);
人均持股:=ROUND(FINANCE(7)/FINANCE(8));
{}
DRAWTEXT_FIX(1,0.008,0.01,0,'基本资料:'),COLORFFCC99;
DRAWTEXT_FIX(1,0.008,0.05,0,'品种类型:'),COLOR99CCFF;
DRAWTEXT_FIX(1,0.008,0.09,0,'行业板块:'),COLOR99CCFF;
DRAWTEXT_FIX(1,0.008,0.13,0,'上市天数:'),COLOR99CCFF;
DRAWTEXT_FIX(1,0.008,0.17,0,'股东人数:'),COLOR99CCFF;
DRAWTEXT_FIX(1,0.008,0.21,0,'人均持股:'),COLOR99CCFF;
{}
DRAWTEXT_FIX(品种类型=1,0.055,0.05,0,'沪 深 A 股'),COLORYELLOW;
DRAWTEXT_FIX(品种类型=2,0.055,0.05,0,' 中 小 板'),COLORYELLOW;
DRAWTEXT_FIX(品种类型=3,0.055,0.05,0,' 创 业 板'),COLORYELLOW;
DRAWTEXT_FIX(1,0.055,0.09,0,HYBLOCK),COLORYELLOW;{行业板块}
{数值}
DRAWNUMBER_FIX(1,0.050,0.13,0,上市天数),COLORGREEN;
DRAWNUMBER_FIX(1,0.050,0.17,0,股东人数),COLORGREEN;
DRAWNUMBER_FIX(1,0.050,0.21,0,人均持股),COLORGREEN;
{单位}
DRAWTEXT_FIX(1,0.08,0.13,0,'天'),COLORWHITE;
DRAWTEXT_FIX(1,0.08,0.17,0,'人'),COLORWHITE;
DRAWTEXT_FIX(1,0.08,0.21,0,'股'),COLORWHITE;
{所属板块}
DRAWTEXT_FIX(1,0.008,0.25,0,'地区板块:')COLOR99CCFF;
DRAWTEXT_FIX(1,0.048,0.25,0,DYBLOCK)COLORGREEN;
DRAWTEXT_FIX(1,0.088,0.25,0,'概念板块:')COLOR99CCFF;
DRAWTEXT_FIX(1,0.128,0.25,0,GNBLOCK)COLORGREEN;
DRAWTEXT_FIX(1,0.008,0.29,0,'风格板块:')COLOR99CCFF;
DRAWTEXT_FIX(1,0.048,0.29,0,FGBLOCK)COLORGREEN;

获利筹码:IF(WINNER(CLOSE),WINNER(CLOSE)*100,0),NODRAW,COLOR0080FF;
净资产:FINANCE(34),NODRAW,COLORRED;
公积金:FINANCE(18),NODRAW,COLORGREEN;
未分利润:FINANCE(32),NODRAW,COLORMAGENTA;
净资收益率:=STRCAT('净资收益率: ',CON2STR(FINANCE(29)/FINANCE(19)*100,2));
每股收益:=STRCAT(' 每股收益: ',CON2STR(FINANCE(38),2));
主营利润率:=STRCAT(' 主营利润率 ',CON2STR(FINANCE(23)/FINANCE(20)*100,2));
当前业绩:=STRCAT(' ',STRCAT(STRCAT(净资收益率,每股收益),主营利润率));
DRAWTEXT_FIX(ISLASTBAR,0.62,1.2,0,当前业绩),COLORRED; {主图显示}
利润增长:FINANCE(43),COLORYELLOW,NODRAW;开幅:100*(O/REF(C,1)-1),COLORYELLOW,NODRAW;

箱顶:HHV(MA((LOW+HIGH+CLOSE+O)/4,5),58),DOTLINE,COLORCYAN,LINETHICK1;
N3:=60;
B3:=EMA(C,3);
B4:=SMA(SMA(B3,2,1),2,1);
LLV(EMA(B4,1),N3),DOTLINE,COLORCYAN,LINETHICK1;

F:EMA(CLOSE,21),COLORRED,LINETHICK2;
IF(F>REF(F,1),F,DRAWNULL),LINETHICK2,COLORRED;
IF(F<REF(F,1),F,DRAWNULL),LINETHICK2,COLORGREEN;

网13:EXPMA(CLOSE,13),COLORGRAY,LINETHICK1;
{黄金分割线}
M:=13;
顶1:=REFDATE(HHV(H,M),DATE);
底1:=REFDATE(LLV(L,M),DATE);
H1:=顶1-(顶1-底1)*0.191;
H2:=顶1-(顶1-底1)*0.382;
H3:=顶1-(顶1-底1)*0.5;
H4:=顶1-(顶1-底1)*0.618;
H5:=顶1-(顶1-底1)*0.809;
顶部:REFDATE(顶1,DATE),COLOR666666;
%19.8:REFDATE(H1,DATE),COLOR666666;
%38.2:REFDATE(H2,DATE),COLOR666666;
%50:REFDATE(H3,DATE),COLOR666666;
%61.8:REFDATE(H4,DATE),COLOR666666;
%80.9:REFDATE(H5,DATE),COLOR666666;
底部:REFDATE(底1,DATE),COLOR666666;
DRAWTEXT(ISLASTBAR,顶部,' 顶部'),COLORGREEN;
DRAWTEXT(ISLASTBAR,%19.8,' 19.8%'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,%38.2,' 38.2%'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,%50,' 50%'),COLORWHITE;
DRAWTEXT(ISLASTBAR,%61.8,' 61.8%'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,%80.9,' 80.9%'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,底部,' 底部'),COLORRED;
{BS标志}
DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2))
AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.98,7);
DRAWICON((ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2))
AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),HIGH*1.02,8);
{箱体}
{
箱顶:PEAK(CLOSE,N,1)*0.98,POINTDOT,LINETHICK3,COLORYELLOW;
箱底:TROUGH(CLOSE,N,1)*1.02,POINTDOT,LINETHICK3,COLORFFFF00;
箱高:100*(箱顶-箱底)/箱底,NODRAW;
};

总额:=AMOUNT;
买:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));
买%:=买/AMOUNT*100;{WWW.GPXIAZAI.COM}
流入:=AMOUNT*买%/10000000000;
流出:=AMOUNT/100000000-流入;
净流:=(流入-流出);
总额3:=SUM(AMOUNT,3);
流入3:=SUM(流入,3);
流出3:=SUM(流出,3);
净流3:=SUM(流入-流出,3);
总额5:=SUM(AMOUNT,5);
流入5:=SUM(流入,5);
流出5:=SUM(流出,5);
净流5:=SUM(流入-流出,5);
总额10:=SUM(AMOUNT,10);
流入10:=SUM(流入,10);
流出10:=SUM(流出,10);
净流10:=SUM(流入-流出,10);
画:=CONST(FINDHIGH(总额10,0,190,1));
DRAWTEXT_FIX(1,0.71,0.07,0,'净流(亿):'),COLORMAGENTA,LINETHICK1;
DRAWTEXT_FIX(1,0.78,0.05,0,'1日'),COLORMAGENTA,LINETHICK1;
DRAWTEXT_FIX(1,0.83,0.05,0,'3日'),COLORMAGENTA,LINETHICK1;
DRAWTEXT_FIX(1,0.88,0.05,0,'5日'),COLORMAGENTA,LINETHICK1;
DRAWTEXT_FIX(1,0.93,0.05,0,'10日'),COLORMAGENTA,LINETHICK1;
DRAWNUMBER_FIX(1,0.78,0.10,0,CONST((净流))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.83,0.10,0,CONST((净流3))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.88,0.10,0,CONST((净流5))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.93,0.10,0,CONST((净流10))),COLORYELLOW;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);MA5:=MA(C,5);MA10:=MA(C,10);MA30:=MA(C,30);
FA:=BARSLAST(CROSS(MA10,MA5))
AND CROSS(MA5,MA10);
FB:=FA AND MA5>MA30 AND MA10>MA30 AND
MA10>REF(MA10,1);

{过左峰提示粉色}
VAR121:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR141:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR161:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR181:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
卖:=(VAR121+VAR141+VAR161+VAR181),LINETHICK2;SQ:DRAWLINE(卖,H,BARSLAST(卖)>=1,REF(H,BARSLAST(卖)),1),COLORWHITE,LINETHICK2;
过峰:=C>SQ AND REF(C,1)<SQ;
VVOL:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
预量:=VVOL/REF(V,1)>1.8;
现量:=V/REF(V,1)>1.5;
过峰1:STICKLINE( 过峰,C,O,5,0)COLORFF00FF;
预量1:DRAWICON(过峰 AND 预量, H*1.01,14);
现量1:DRAWICON(过峰 AND 现量,(O+C)/2,23);
前次低点:LLV(L*1,250)POINTDOT,COLORFF00FF,LINETHICK4;

 
自用的综合指标 通达信主图/副图指标 源码 贴图
打开微信扫一扫,一键复制指标源码,
轻松快捷粘贴至手机通达信APP中。
0

本站提示:股市有风险,入市请慎重,资料由股票下载网整理收集

找不到你要的公式?给我们建议

  1. 股票软件
    股票分析软件
    股票交易软件
    股票行情软件
    指标股票池
    手机炒股软件
    书籍教程
    数据软件
    工具补丁
    大智慧
    通达信
    飞狐
    东方财富通
    操盘手
    指南针
    分析家
    同花顺
    钱龙
    证券之星
    券商股票软件
    特色行情软件
    迷你行情软件
    金融界软件
    美股外盘软件
    大智慧股票池
    通达信股票池
    大智慧L2公式
    通达信公式
    飞狐公式
    同花顺公式
    股票书藉
    视频教程
    金融书籍
    其他书籍
    资讯评测软件
    资金分析软件
    数据接口软件
    江恩波浪软件
    数据下载软件
    软件数据投资
    选股软件
    登录补丁
    其他应用
    股软教程
  2. 股票公式
    通达信公式
    大智慧公式
    飞狐公式
    同花顺公式
    东方财富通公式
    金字塔指标公式
    文华指标公式
    MT4指标
    博易大师指标
    公式教程答疑
  3. 炒股知识
    短线技巧
    软件公式
    炒股视频
    股票入门
    股市实战信息交流
    炒股技巧
    股票基础知识
    技术分析
    炒股一招先
    基本面分析
    股票视频教程
    股票买卖技巧
    k线图分析
    胡立阳教你买股票
    短线炒股技巧
    天狼之眼
    波浪理论技术讲解
    股市赢家杨百万
    股票理论、T0缠论、知识
    经典指标、交易系统
    成交量能、筹码分析
    买卖信号、技术分析
    挖坑、冼盘、吸筹、出货
    均线战法、黄金分割
    经典K线、趋势形态
    牛股黑马、王子理论
    涨停、周线、月线
    止盈、止损、支撑、压力
    案例、波浪、口诀、选股
    分时、盘口、补仓、解套
  4. 技术指标
    DDX
    DDY
    DDZ
    MACD
    KDJ
    CCI
    OBV
    BOLL
    RSI
    VOL
    CR
    WR