»查看更多分类股票软件

个股与大盘强弱对比指标-(简单明确 通达信源码)

发布时间:2010-05-19 08:49:00  点击:

大家在很多时候都是用图形叠加的办法对个股与大盘的走势进行对比,但这样一般图形会发生错位,对比效果一般不怎么好,前段时间正好应一网友要求,写个大盘副图指标,就是在副图里画出大盘的K线,在此基础上加上了一段时间内的统计数据。时间参数N可随意设定。

{大盘强弱}
最高指数:INDEXH,LINETHICK0;
最低指数:INDEXL,LINETHICK0;
开盘指数:INDEXO,LINETHICK0;
收盘指数:INDEXC,LINETHICK0;
大盘涨幅:(INDEXC-REF(INDEXC,1))/REF(INDEXC,1)*100,LINETHICK0;

个股涨幅:=(C-REF(C,1))/REF(C,1)*100;
i:=COUNT(大盘涨幅<个股涨幅 ,N);
大盘:=(INDEXC-REF(INDEXC,N))/REF(INDEXC,N)*100;
个股:=(C-REF(C,N))/REF(C,N)*100;

IF DISPSTATUS=2 and 大盘<个股 THEN DRAWTEXTREL(10,570,'最近'+NUMTOSTRN(N,0)+'个交易日与大盘对比:涨幅强于大盘'),COLOR00EEff;
IF DISPSTATUS=2 and 大盘>个股 THEN DRAWTEXTREL(10,570,'最近'+NUMTOSTRN(N,0)+'个交易日与大盘对比:涨幅弱于大盘'),COLOR00EEff;
IF DISPSTATUS=2 THEN DRAWTEXTREL(10,650,'大盘累计涨跌幅:'+NUMTOSTRN(大盘,3)),COLOR00EEff;
IF DISPSTATUS=2 THEN DRAWTEXTREL(10,730,'个股累计涨跌幅:'+NUMTOSTRN(个股,3)),COLOR00EEff;
IF DISPSTATUS=2 THEN DRAWTEXTREL(10,810,'强于大盘:'+NUMTOSTRN(i,0)+'天'),COLOR00EEff;
IF DISPSTATUS=2 THEN DRAWTEXTREL(10,890,'弱于大盘:'+NUMTOSTRN((N-i),0)+'天'),COLOR00EEff;

STICKLINE(INDEXA>0 and INDEXO<INDEXC,INDEXO,INDEXC,6,0),COLORRED;
STICKLINE(INDEXA>0 and INDEXO>INDEXC,INDEXC,INDEXO,6,0),COLORGREEN;
STICKLINE(INDEXA>0 and INDEXO<INDEXC,INDEXH,INDEXL,1,0),COLORRED;
STICKLINE(INDEXA>0 and INDEXO>INDEXC,INDEXH,INDEXL,1,0),COLORGREEN;

0
本站提示:股市有风险,入市请慎重,资料由股票下载网整理收集

找不到你要的文章?给我们建议

  1. 股票软件
    股票分析软件
    股票交易软件
    股票行情软件
    指标股票池
    手机炒股软件
    书籍教程
    数据软件
    工具补丁
    大智慧
    通达信
    飞狐
    东方财富通
    操盘手
    指南针
    分析家
    同花顺
    钱龙
    证券之星
    券商股票软件
    特色行情软件
    迷你行情软件
    金融界软件
    美股外盘软件
    大智慧股票池
    通达信股票池
    大智慧L2公式
    通达信公式
    飞狐公式
    同花顺公式
    股票书藉
    视频教程
    金融书籍
    其他书籍
    资讯评测软件
    资金分析软件
    数据接口软件
    江恩波浪软件
    数据下载软件
    软件数据投资
    选股软件
    登录补丁
    其他应用
    股软教程
  2. 股票公式
    通达信公式
    大智慧公式
    飞狐公式
    同花顺公式
    东方财富通公式
    金字塔指标公式
    文华指标公式
    MT4指标
    博易大师指标
    公式教程答疑
  3. 炒股知识
    短线技巧
    软件公式
    炒股视频
    股票入门
    股市实战信息交流
    炒股技巧
    股票基础知识
    技术分析
    炒股一招先
    基本面分析
    股票视频教程
    股票买卖技巧
    k线图分析
    胡立阳教你买股票
    短线炒股技巧
    天狼之眼
    波浪理论技术讲解
    股市赢家杨百万
    股票理论、T0缠论、知识
    经典指标、交易系统
    成交量能、筹码分析
    买卖信号、技术分析
    挖坑、冼盘、吸筹、出货
    均线战法、黄金分割
    经典K线、趋势形态
    牛股黑马、王子理论
    涨停、周线、月线
    止盈、止损、支撑、压力
    案例、波浪、口诀、选股
    分时、盘口、补仓、解套
  4. 技术指标
    DDX
    DDY
    DDZ
    MACD
    KDJ
    CCI
    OBV
    BOLL
    RSI
    VOL
    CR
    WR